Jump to content

Welcome to GTINI

Welcome to GTINI, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of GTINI by signing in or creating an account.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.

Sign in to follow this  
ger16v

corrado g60 brake bleeding

Recommended Posts

Hello i am having difficulty belled the brakes to my corrado g60 

i managed to do the calipers ok and the clutch master cylinder - all run free with plenty of fluid

however the brake master cylinder once opened pushes about a 50mm of fluid into a tube and thats it!

i have not touched the reservoir bleed point

iam using the eazibleed unit - uses 20psi pressure 

i read somewhere that the abs pump needs bled also - where do you bleed this - plenty of bolts on it 

but dont want to open the wrong one.

 

thanks

Share this post


Link to post
Share on other sites

I done the rears first then the front  then the master cylinder and finally the clutch

when the brakes were done I moved to under the bonnet. Bentley manual says that you bleed master cylinder first before the clutch to me seems strange to me as we all know air rises to the top and I would of assumed that you start at the bottom.

bleeding the abs pump I have seen mentioned but cannot locate an obvious point on the unit

the rears took a long time to do and I had to manually adjust the bias valve in order to get things moving also had a few small leaks but a quick tighten of the nipples sorted it out - always afraid of over tightening these things.

the car has not run in over 2 years now and was hoping to get it started yesterday only to find the fuel pump is not running. I can hear the relay clicking but pump is not priming and of course I went to get my multimeter and it is dead also the fuel gauge is working which may indicate that the pump is dead.

Edited by ger16v
addition

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×