Jump to content

Welcome to GTINI

Welcome to GTINI, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of GTINI by signing in or creating an account.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.

clrrk

Steering Torque Sensor

Recommended Posts

This has been annoying me for a while so decided to look into it more tonight as I've MOT looming at the end of October. The first day I picked up the MK5 I went to overtake a cyclist and found myself having a disagreement with a series of cats eyes at Lake Ogwen which resulted in the steering light on the dashboard lighting up amber. Scanned it with VAGCOM and it said that the steering angle sensor has an implausible signal. Done a quick search online and all I can seem to find are posts by Carson trying to get the light to go away after he changed his steering rack. Does anyone have any idea of how I can resolve this? I'm guessing best case scenario is that a plug has come out or some wiring is damaged, worst case my rack is buggered

Share this post


Link to post
Share on other sites

So update on this. Gavin Black came round tonight and we went through the full Ross Tech reset. Steering Angle sensor reset worked fine and then we done the following reset for Steering Limit Stop Adaption.

 

Steering Limit Stop Adaptation

(Engine still running)

  • Center steering wheel (±10°) and hold it centered for 5 seconds.
  • Turn steering wheel completely to the left and hold it there for 10 seconds.
  • Turn steering wheel completely to the right and hold it there for 10 seconds.
  • Center steering wheel (±10°).
  • Switch OFF engine and ignition.
  • Switch ON ignition.
  • Wait 5 seconds.
  • Steering Assist Warning Lamp should turn OFF. If it doesn't, perform a short test drive.

When we done this we lost power steering, so we tried going through it again holding the wheel for 30 seconds - still no power steering. Checked the faults on it and it came up with Power Steering Control Module J500 - No Signal/Communication - No basic settings.

 

Gav found a link somewhere that said try doing it for 2 seconds instead - so we done this, power steering came back, went for a drive and the light went off. Parked the car up and when I went to move it later on in the evening the light has came back on.

Anyone got any ideas? Where are we going wrong?

Share this post


Link to post
Share on other sites

I know this was a good while ago but did you ever find a solution to this? As I have had the exact same problem, had to get the light taken out for mot and my wheel is not sitting straight. Banged a cats eye off the sub frame and the power steering cut off but turned the car off and on and the power steering came back on. Have tried the typical resets of turning the steering wheel lock to lock etc and no joy. If I clear the codes the light stays off until the car is turned off and on. Now I know my alignment is out at the rear as the bolts in the bush attached to the spring carrier are seized in place.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×