Jump to content

Welcome to GTINI

Welcome to GTINI, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of GTINI by signing in or creating an account.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.

Sign in to follow this  
marco-sparco

TT speedo not working.

Recommended Posts

Well folks been a while since I posted on here. But driving the TT this morning and once over around 20-25 mph there was a click and the speedo stopped. It then was reading 80mph when pulling out of a junction which was impossible lol. It sort of seems that when I lift my foot off the accelerator the needle goes down to zero and once accelerating it creeps up very slowly until the next gear change. I know the dash cluster can be a common fault with them but this was all replaced last year before I bought the car so hopefully that isn't the case again. It's an 01 225 model. If anyone has any ideas give me a shout cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×